Skocz do zawartości
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

Promowane odpowiedzi

SeNioR    6,712

Autor: Senky
Opis: Modyfikacja dodaje Ajax na forum przez co korzystanie z forum staje się szybsze i wygodniejsze. Ajax jest w "Kto jest na forum", "Statystykach" oraz w  "Podglądzie tematu"
Pobierz:

ajaxbase.zip

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Podobna zawartość

    • Przez sztywan.
      Cześć, próbuje stworzyć formularz logowania za pomocą ajax i php. Mam taki prosty kod:
      <script> $(document).ready(function() { var form = $("#login_form").serialize(); $.ajax({ type: 'POST', url: 'action/login.php', data: form, beforeSend: function() { $("#info").html("Trwa sprawdzanie danych..."); } success: function(response) { if(response == "ok") { setTimeout("window.location.href = dashboard.php", 4000); } else { $("#info").html(response); } } }); }); </script> I taki plik login.php, w którym znajduje się:
      <?php if(isset($_POST['login_button'])) { $admin_email = $_POST['input_email']; $admin_password = $_POST['input_password']; $password = md5($admin_password); $admin = $database->query("SELECT * FROM `admin_users` WHERE password=$password"); if($admin->num_rows > 0) { echo "ok"; $_SESSION['admin_email'] = $admin_email; $_SESSION['admin_login'] = true; } } ?> I gdy wchodzę na stronie w konsoli wyświetla się taki błąd.
      Ale w linii 58 znajduje się to:
      url: 'action/login.php', Sprawdziłem wszystko, moim okiem i nie widzę  żeby brakowało gdzieś klamry.
      Tutaj macie link do dema, gdzie wszystko pisze: NetherShop - Darmowy sklep SMS dla twojego serwera Minecraft!
    • Przez cskopytko
      Witam, napisałem własny skrypt chatu, lecz nie wiem jak zrobić, że po dodaniu nowego wpisu przez innego użytkownika, aby automatycznie dodało wszystkim ten wpis.
      Jakieś sugestie?
    • Przez daaav
      Witam, mam problem, mianowicie podczas instalacji w kroku pierwszym nie wykrywa mi PHP7, forum instaluje na XAMPIE, który pobierałem z wersją PHP7, więc nie wiem w czym problem ;/
      Gdy w XAMPIE wejdę w PHPInfo jest napisana aktualna wersja PHP --> PHP Version 7.0.13, w PHPMyAdmin również jest napisana taka sama wersja, lecz podczas pierwszego korku instalacji mam napisane, że nie mam wersji PHP7+, więc w czym może być problem?
      Dodam, że w zakładce "Applications" w XAMPP`ie mam taki komunikat: "We are working on making Bitnami add-ons available for PHP 7, it is possible the current add-ons do not work well with this version." Ale na poniższych ss`ach widać, że wersja PHP to 7.
      Próbuje zainstalować PHPBB 3.2.0, ale na niższej wersji również miałem taki sam problem. (Problem nie występuje, gdy pobrałem phpbb z polskiego forum, phpbb.pl bodajże)
      SS`Y --> http://imgur.com/a/mZtVC
      Wcześniej już zadawałem to pytanie, ale wówczas zmieniłem php_value mbstring.http_input na pass i wszystko działało.
    • Przez X3nO
      Witam, mam problem z modułem ajaxu, mianowicie identyczny problem:
       
      http://forum.invisionize.pl/topic/48702-nopermission-w-ajax/
       
      Stworzyłem moduł ajax, kontroler "changes" i dodałem defaultSection, kod popua:
      <li><a id="changesModal2" href="index.php?app=goldPanel&module=ajax&section=changes">Ostatnie zmiany</a></li> <script type='text/javascript'> $('changesModal2').observe( 'click', function(e) { _var = new ipb.Popup( 'changesModalWindow', { type: 'pane', hideAtStart: false, modal: true, ajaxURL: $(this).readAttribute('href'), w: '750px', h: 600}); Event.stop(e); return false; }); </script> Plik changes.php:
      <?php if ( ! defined( 'IN_IPB' ) ) { print "<h1>Incorrect access</h1>You cannot access this file directly. If you have recently upgraded, make sure you upgraded 'admin.php'."; exit(); } class public_goldPanel_ajax_changes extends ipsAjaxCommand { public function doExecute( ipsRegistry $registry ) { $this->lang->loadLanguageFile( array( 'public_lang' ), 'goldpanel' ); return $this->returnHtml( $this->registry->output->getTemplate('goldPanel')->changes() ); } } ss: 
    • Przez Aciel
      Witam, w ramach konserwacji Przema (niestety muszę się wstrzymać na razie z migracją) natrafiłem na kolejny problem.
      Po wysłaniu wiadomości w shotboxie wiadomość jest widoczna dopiero po ręcznym odświeżeniu strony, pomimo że shoutbox jest w domyśle ajaxowy.
       
      Wyrzucam jakieś błędy z javascriptem, możecie rzucić okiem?
      shoutbox.php
      shoutbox_view.php
      shoutbox_body.tpl
      shoutbox.js
      overall_header.tpl
  • Ostatnie tematy

×