Skocz do zawartości
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

Wincode

Kod PHP wyświetla się jako komentarz HTML

Promowane odpowiedzi

Wincode    11

Dlaczego kod PHP jest wyświetlany jako komentarz?

 

Mój index.php

<html>
<head>
<link rel="stylesheet" href="css/style.css">
<title>Pierwszy skrypt php</title>
</head>
<body>
<?php
echo "Prz2342432 stronie";
?>
</body>
</html>

 

image.png.628f8f32f8d31bde72db511bf797d373.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Wincode    11
Teraz, rogue napisał:

Mam jedno pytanie, Ty to odpalasz na jakimś serwerze WWW czy ze swojego dysku? 

 

XAMPP

Edytowane przez Wincode

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Lord Fenrir    611

Według mnie XAMPP może być źle skonfigurowany bo taki rezultat otrzymuje się jak plik .php jest czytany z dysku i nie przechodzi przez żaden serwer / wirtualny serwer.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Wincode    11
Teraz, rogue napisał:

Według mnie XAMPP może być źle skonfigurowany bo taki rezultat otrzymuje się jak plik .php jest czytany z dysku i nie przechodzi przez żaden serwer / wirtualny serwer.

 

Fora takie jak IPB czy MyBB działają bez problemu, więc chyba nie w tym problem.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
ShanonWEB    724

Problemem jest link przez który wchodzisz.

Wchodząc przez, np.:

file:///E:/xampp/htdocs/88/index.php => będzie problem jak na screenie, ale wchodząc z linku, np.:

localhost/88/index.php będzie wszystko działać poprawnie

  • Lubię to! 1
  • Wrr 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Wincode    11
3 minuty temu, ShanonWEB napisał:

Problemem jest link przez który wchodzisz.

Wchodząc przez, np.:

file:///E:/xampp/htdocs/88/index.php => będzie problem jak na screenie, ale wchodząc z linku, np.:

localhost/88/index.php będzie wszystko działać poprawnie

 

Nie, nie chodzi o to - sprawdzałem to.

Gdy mam <? wtedy nie działa lecz gdy jest <?php wtedy wszystko działa.

Edytowane przez Wincode

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
arces    85

Jakiej wersji PHPa używasz? Znacznik <? chyba już jest nieaktywny dla tych nowszych wersji? Zresztą według mnie <?php jest bardziej czytelne, a to tylko 3 znaki więcej.

  • Wrr 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony.


×