Skocz do zawartości
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

Amciek

[phpBB3] General Error. SQL ERROR [mysql4] Can't Connect to Mysql server on

Promowane odpowiedzi

Amciek    6

Witam, wgrałem kopię bazy danych z innego hostingu na inny i wyskakuje taki błąd:

 

acarugeospljaybplykflvjntjvbbigmmkljtodi

 

Proszę o pomoc bo nie wiem co teraz robić. Niby coś mam edytować w plikach czy coś..

I jeszcze pytanie ja mam po prostu to wgrać ten backup bazy czy stworzyć nową bazę i grać to jako sql?

Forum phpBB3

Adres: vtransport.pl

Proszę o pomoc.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

1. Eksportujesz sobie bazę z obecnego hostingu do pliku SQL.

2. Zakładasz nową bazę z takim samym kodowaniem znaków i nazwą, bez tabel.

3. Importujesz skrypt SQL.

4. Jeżeli bazę masz na tym samym hoście co forum to jako adres bazy podajesz localhost, a nie nazwę domenową.

5. Jeżeli bazę masz na innym hoście to musisz zadbać o skonfigurowanie dostępu do niego dla skryptu forum (sprawdź czy serwer MySQL nie nasłuchuje tylko na interfejsie lokalnym).

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
SeNioR    6,716

3 prawdopodobne przyczyny:

 

1. Źle wgrałeś bazę

2. Przekroczyłeś dostępne miejsce na serwerze lub bazie MYSQL

3. Poprawiłeś plik config.php po przeniesieniu? (localhost, nazwa użytkownika, nazwa bazy danych, hasło)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
SeNioR    6,716

Problem rozwiązany. Przyczyną była zła konfiguracja pliku config.php oraz błąd bazy danych, po naprawieniu i dodaniu prefiksu do tabel forum zaczęło działać..

 

Poprawna konfiguracja pliku config.php dla hostingu xaa.pl config.rar

 

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony.


  • Podobna zawartość

    • Przez Akeno
      Witam,
       
      mam problem z forum na silniku IPS 4.2.6  po paru modernizacjach stylu odraz wgraniu tabelki serwerów strona zaczęła dziwnie lagować po chwili to ustąpiło jednak pojawił się error "Coś poszło nie tak (ಠ_ಠ) Proszę spróbować ponownie." na białym tle. Panel administracyjny nie działa wyświetla totalnie to samo. Link do forum: http://advgaming.pl/forum/
       
      Jeśli ktoś ma jakieś podejrzenia lub wie co mogło to spowodować proszę o szybką pomoc.
       
      Pozdrawiam
    • Przez mefisteoo
      Siema!
      Mam bazę danych:

       
      I chcę aby w PHP wyświetlało mi 3 najnowsze posty (najnowsza data (kolumna: DATA))
      np. ID: 4 , 2 i 1 bo zostały dodane najpóźniej
       
      Rozumiecie? 
       
      Tu mam plik najnowsze-posty.php
       
      <?php require_once "polacz.php"; $polaczenie = @new mysqli($host, $db_user, $db_password, $db_name); if ($polaczenie->connect_errno!=0) { echo "Error: ".$polaczenie->connect_errno; } else { $query = mysqli_query($polaczenie ,'select * from posty'); while($rekord = mysqli_fetch_array($query)) { $naz = '<li><a href="news.php?id='.$rekord[0].'">'.$rekord[1].'</a> Autor: '.$rekord[3].' - '.$rekord[2].'</li>'; } echo '<ul>'.$naz.'</ul>'; } ?>  
    • Przez Marosking.
      Cześć, mam o to taki kod php.
      <?php session_start(); include 'inc/database.conncect.php'; $info = ''; if(isset($_POST['register_input'])) { $register_email = $_POST['register_email']; $confirm_register_email = $_POST['confirm_register_email']; $register_password = $_POST['register_password']; $confirm_register_password = $_POST['confirm_register_password']; $register_nick = $_POST['register_nick']; if((!empty($register_email)) && (!empty($confirm_register_email)) && (!empty($register_password)) && (!empty($confirm_register_password)) && (!empty($register_nick))) { if($register_email == $confirm_register_email) { if($register_password == $confirm_register_password) { $_SESSION['user_nick'] = $register_nick; $_SESSIOM['user_login'] = true; $database->query("INSERT INTO `users` VALUES ('$register_email', '$register_nick', '$register_password', 'now()', 'now()', '1', '0', '0')"); $info = '<div class="alert alert-success" role="alert">Rejstracja została zakończona. Wejdź na email, aby dokończyć rejestracje.</div>'; } else { $info = '<div class="alert alert-danger" role="alert">Podane hasła nie zgadzają się.</div>'; } } else { $info = '<div class="alert alert-danger" role="alert">Podane adresy email nie pasują do siebie</div>'; } } else { $info = '<div class="alert alert-danger" role="alert">Musisz wypełnić wszystkie pola.</div>'; } } ?> I taki formularz.
      <div class="col col-md-6"> <blockquote class="blockquote"> <p class="mb-0">Rejstracja</p> <footer class="blockquote-footer">Chcesz dołączyć do naszych użytkowników? Zrób to teraz!</cite></footer> </blockquote> <?php echo $info; ?> <form method="post"> <div class="form-group"> <label for="register_email">Adres email</label> <input type="email" class="form-control" id="login_email" name="register_email" placeholder="Wpisz swój adres email"> </div> <div class="form-group"> <label for="confirm_register_email">Powtórz adres email</label> <input type="email" class="form-control" id="login_email" name="confirm_register_email" placeholder="Wpisz ponownie swój adres email"> </div> <div class="form-group"> <label for="register_password">Hasło</label> <input type="password" class="form-control" id="login_password" name="register_password" placeholder="Wpisz swoje hasło"> </div> <div class="form-group"> <label for="confirm_register_password">Powtórz hasło</label> <input type="password" class="form-control" id="login_password" name="confirm_register_password" placeholder="Wpisz ponownie swoje hasło"> </div> <div class="form-group"> <label for="register_nick">Nazwa użytkownika</label> <input type="password" class="form-control" id="login_password" name="register_nick" placeholder="Wpisz swoją nazwe użytkownika"> </div> <input type="submit" class="btn btn-primary" value="Zarejetruj się" name="register_input"> </form> </div> I gdy klikam przycisk do rejestracji wyskakuje mi błąd:
      Fatal error: Call to a member function query() on null in /profiles/l/ls/lsf/lsforum/ls-forum.c0.pl/lsmods/panel/users/index.php on line 21 I wychodzi na to że błąd jest w linijce 21, a tu jest:
      $database->query("INSERT INTO `users` VALUES ('$register_email', '$register_nick', '$register_password', 'now()', 'now()', '1', '0', '0')"); Ale co tutaj jest źle? Z góry dziękuje za pomoc.
    • Przez YoutuberAidis
      Jak odblokować ze jak mam na vps mysql i che polaczyc z poza vps np z proserwer
    • Przez daav`
      Witam, mam problem, mianowicie podczas instalacji w kroku pierwszym nie wykrywa mi PHP7, forum instaluje na XAMPIE, który pobierałem z wersją PHP7, więc nie wiem w czym problem ;/
      Gdy w XAMPIE wejdę w PHPInfo jest napisana aktualna wersja PHP --> PHP Version 7.0.13, w PHPMyAdmin również jest napisana taka sama wersja, lecz podczas pierwszego korku instalacji mam napisane, że nie mam wersji PHP7+, więc w czym może być problem?
      Dodam, że w zakładce "Applications" w XAMPP`ie mam taki komunikat: "We are working on making Bitnami add-ons available for PHP 7, it is possible the current add-ons do not work well with this version." Ale na poniższych ss`ach widać, że wersja PHP to 7.
      Próbuje zainstalować PHPBB 3.2.0, ale na niższej wersji również miałem taki sam problem. (Problem nie występuje, gdy pobrałem phpbb z polskiego forum, phpbb.pl bodajże)
      SS`Y --> http://imgur.com/a/mZtVC
      Wcześniej już zadawałem to pytanie, ale wówczas zmieniłem php_value mbstring.http_input na pass i wszystko działało.
  • Ostatnie tematy

×