Skocz do zawartości
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

Gość DR HOUSE

Problem z aktualizacją

Promowane odpowiedzi

Gość DR HOUSE

Cześć,


Postanowiłem, że wersja IPS jest już dość zaawansowana więc można spokojnie na nią przejść, pobrałem pliki z panelu i wgrałem, ku mojemu zdziwieniu zamiast instalatora widzę błąd:

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/xxxxx/public_html/noweips/admin/index.php on line 13

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/xxxxx/public_html/noweips/admin/index.php on line 13

Parse error: syntax error, unexpected T_STRING in /home/xxxxx/public_html/noweips/admin/index.php on line 13

(W xxxxx był mój login dlatego ukryłem, żeby nie było, że coś się staram ukryć dziwnego)

 

Plik wygląda tak:

<?php
/**
 * @brief		Admin CP bootstrap
 * @author		<a href='http://www.invisionpower.com'>Invision Power Services, Inc.</a>
 * @copyright	(c) 2001 - SVN_YYYY Invision Power Services, Inc.
 * @license		http://www.invisionpower.com/legal/standards/
 * @package		IPS Social Suite
 * @since		18 Feb 2013
 * @version		SVN_VERSION_NUMBER
 */

require_once '../init.php';
\IPS\Dispatcher\Admin::i()->run();

 

No więc jest fajnie bo za diabła nie wiem o co chodzi, próbowałem przez 15 minut na różne sposoby wymusić mu tą instalację i nic. Tym razem wysiadam i bez pomysłów nie ogarnę.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

IPS korzysta z namespace a na Twoim serwerze musi być wersja PHP starsza niż 5.3, ponieważ starsze wersje nie wspierają tego.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

No tak, brawa dla mnie, że o tym nie pomyślałem... Co ciekawe sprawdzałem plikiem z linku Czarka i pisało, że wersja PHP jest 5,4

 

Dzięki naXe za informacje :)

 

Edit:

no tak, już wiem - przy aktualizacji usunąłem wszystkie pliki razem z htacces gdzie była zapisana informacja jaka wersja PHP ma się uruchamiać...

Edytowane przez DR HOUSE

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

An installation has already been activated for this license key. Your license key entitles you to one installation only. If you need to change the URL associated with your license, contact IPS technical support.

Taaa, fajnie tylko ciekawe gdzie ta instalacja...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeżeli tylko aktualizujesz to musisz użyć convertera tej bazy.

Potem wgrać silnik ips, w configu wszystko wpisać i wejść do adresu twojastrona.pl/admin/upgrade

czy jakoś tak tam wpisujesz dane do p@ no i aktualizuje ci się i powinno działać.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

Tak robię, nie mam problemu z aktualizacją tylko odziwo z kluczem o który pyta w 3 kroku/

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

Próbowałem, wtedy wywala, że już uruchomiono tą opcję... i mam w panelu 2x ten sam adres jako normalny i jako test.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

Gdybyś mógł napisać (chociaż na pw to będę wdzięczny), mam licencję a nie mogę zaktualizować silnika, bez żartów.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Gdybyś mógł napisać (chociaż na pw to będę wdzięczny), mam licencję a nie mogę zaktualizować silnika, bez żartów.

Napisz zgłoszenie do IPS.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Gdybyś mógł napisać (chociaż na pw to będę wdzięczny), mam licencję a nie mogę zaktualizować silnika, bez żartów.

Wrzuć plik init.php ( z nulleda) do swojego forum. Zrób to co masz zrobić i podmień na swój plik.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Bez żadnego podmieniania plików można pominąć podawanie klucza podczas instalacji.
Twój pomysł jest debilny, ale chociaż wiadomo kto używa nielegalnie skryptów ;)

Więc, aby pominąć podanie klucza należy w adresie strony zamienić license na applications. W ten sposób krok Licencja zostanie pominięty, a instalator przejdzie do kroku następnego, czyli Aplikacje.

  • Lubię to! 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Bez żadnego podmieniania plików można pominąć podawanie klucza podczas instalacji.
Twój pomysł jest debilny, ale chociaż wiadomo kto używa nielegalnie skryptów ;)

Więc, aby pominąć podanie klucza należy w adresie strony zamienić license na applications. W ten sposób krok Licencja zostanie pominięty, a instalator przejdzie do kroku następnego, czyli Aplikacje.

Od wersji bodajże 4.0.13.1 już to nie działa

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość DR HOUSE

Napisz zgłoszenie do IPS.

Napisałem ale na razie jest cisza niestety a mnie zależy na czasie póki mam wolną chwilę.

 

Wrzuć plik init.php ( z nulleda) do swojego forum. Zrób to co masz zrobić i podmień na swój plik.

Dziękuję za pomoc ale wolałbym nic z niewiadomego pochodzenia nie pobierać bo potem mogą wyjść dziwne rzeczy.

 

Bez żadnego podmieniania plików można pominąć podawanie klucza podczas instalacji.
Twój pomysł jest debilny, ale chociaż wiadomo kto używa nielegalnie skryptów ;)

Więc, aby pominąć podanie klucza należy w adresie strony zamienić license na applications. W ten sposób krok Licencja zostanie pominięty, a instalator przejdzie do kroku następnego, czyli Aplikacje.

Dziękuję, to działa! Daję oczywiście plusika.

PS
Żeby nie było, że szukam obejścia na nielegalną licencję - wszystko mam tylko nie mogłem zrobić aktualizacji przez jakiś błąd z winy IPSu (tak uważam).

 

Dobra, chyba wszystko jest fajnie i działa! Dzięki Panowie!

Edytowane przez DR HOUSE

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

×