Skocz do zawartości
Pecetowicz Forum komputerowe

john jest na Pecetowiczu.

Aby wyświetlić pełny profil i móc skontaktować się z john, zaloguj się lub utwórz konto.

john

Użytkownik
  • Zawartość

    25
  • Dołączył

  • Ostatnia wizyta

  • Wygrane

    1

Ostatnia wygrana john w dniu 29 Lipca 2019

Użytkownicy przyznają john punkty reputacji!

Reputacja

22 Przyzwoita

1 obserwujący

O john

  • Tytuł
    Żółtodziób

Ostatnie wizyty

275 wyświetleń profilu
  1. Musiałem jeszcze zaokrąglić te wartości i działa, ale nie do końca. Najpierw pokażę screeny, a później wyjaśnię: W headerze jest podana wartość według tego kodu Math.round($(document).height() - $(window).height()) == Math.round($(window).scrollTop()) Jak widać na pierwszym screenie, gdy pasek z adresem strony jest rozwinięty, wtedy osiągam zamierzony efekt, w przypadku, gdy się schowa, scrollTop() strony jest mniejszy. Czy jest jakaś funkcja, która umożliwia wykrywanie tego, kiedy pasek zmienia swój stan? Bo jeśli z góry dodam 56 px do wartości scrollTop(), to w pr
  2. Witajcie, mam pewien problem z moim skryptem. Ma się wywoływać za każdym razem, gdy użytkownik dojedzie na sam dół strony (później pomyślę o funkcji throttle, żeby to trochę zoptymalizować), o ile na komputerze działa to prawidłowo, tak na urządzeniach mobilnych już niekoniecznie. Tutaj jest przykładowy kod: $(document).scroll(function() { if($(window).scrollTop() + $(window).height() == $(document).height()) { alert("Jestem na dole"); } }); Wyświetliłem nawet te wartości na stronie, aby zobaczyć, co powyższemu kodowi dolega: $("body").html($(window).scrollTop() + $(window).
  3. Witajcie, tytuł tematu raczej zdradza czego dotyczy ten wątek. Mam laptopa o takiej specyfikacji: Windows 10 (64 bit), 8 GB RAM, Procesor Intel i5-410N 2.70 GHz, Grafika integra intel hd graphics 4600, Dysk ssd 120 GB. Z tego co wiem na takim laptopie gta ruszy, niekoniecznie na super grafice, ale na tym mi aż tak nie zależy bo miałem ograniczony budżet. Laptop kupiony, GTA kupione ale pojawił się problem - brak miejsca na dysku. Liczyłem na to, że gra się zmieści bez problemu, zainstalowała się no ale napotkałem niespodziankę w postaci aktualizacji 30
  4. Użyłem Twojego rozwiązania, ale nadal nie działa (ten sam błąd), podałem tam parametr, nawet zadeklarowałem wcześniej jakąś zmienną $test = "value"; $this->output($test); I nadal jest to samo. Mam się jakoś odwołać do tego parametru w init() lub w szablonie? Przepraszam, ale no niestety nie potrafię tego zrozumieć. Wrzucę po prostu całość mojego pliku z widgetem, chociaż nic tam takiego nie zmieniałem: <?php /** * @brief jhnserverlist Widget * @author <a href='https://www.invisioncommunity.com'>Invision Power Services, Inc.</a> * @copyright (c) Invision Powe
  5. Witajcie, tworzę własną aplikację, nigdy nie miałem wcześniej styczności z tworzeniem własnych widgetów i niestety natrafiłem na przeszkodę. Póki co chciałem po prostu wyświetlać w nim jakikolwiek tekst, żeby zobaczyć, czy to w ogóle działa, no i jak się okazuje - nie. public function init() { $this->template( array( \IPS\Theme::i()->getTemplate( 'plugins', 'core', 'global' ), $this->key ) ); parent::init(); } public function render() { $this->output(); } oraz kod szablonu znajdującego się w dev/html/jhnserverlist.phtml <ips:template parameters="" /
  6. Robię to przez style bo niestety nie mogę dobrać się do core/global/prefix przez hooki w aplikacji (chciałem podmienić całą jego zawartość na moją). Dziękuję za moment sprawdzę czy działa.
  7. Cześć, to znowu ja no i ponownie mam problem, z którym chwilę się już męczę. To jest niby proste, ale nie mam pojęcia dlaczego nie działa mi poprawnie. Mam taki oto kod: {{$query = \IPS\Db::i()->select( 'prefix_prefix, prefix_text, prefix_suffix', 'jhntopicprefixes_prefixes', array( 'prefix_text=?', strtolower($text)) ); }} {{if $query}} {{foreach $query as $row}} {$row->prefix_prefix} {$row->prefix_text} {$row->prefix_suffix} {{endforeach}} {{endif}} Który niestety zwraca mi pusty ciąg. Chciałbym pobrać trzy wartości z tabeli gdzie jest spełniony jakiś warune
  8. Dziękuję, działa, nie przemyślałem tego :p.
  9. Witajcie, mam pewien problem. W moich tematach od czasu do czasu będzie pojawiał się kod html (zazwyczaj znacznik span z jakimś stylem) i taki efekt w title mnie nie zadowala: Szukałem rozwiązania w internecie i dowiedziałem się, że funkcja w php strip_tags rozwiązuje mój problem, to znaczy usuwa wszystkie znaczniki html. Spróbowałem napisać taki kod, jednakże niestety z jakiegoś względu nie działa tak, jak powinien: {{$jhn_title = output.getTitle( $title );}} {expression="strip_tags($jhn_title)"} Szukałem również w dokumentacji ipsa, czy istnieje jakiś dodatkowy atryb
  10. Tak, dokładnie tak. Moje rozwiązanie dodaje nowy Widget Container, czyli miejsce, gdzie możesz dodawać swoje widgety. Domyślnie masz trzy header, sidebar i footer. Po prostu po skorzystaniu z mojego rozwiązania odśwież stronę, kliknij na strzałkę z lewej strony odpowiedzialną za wyświetlanie bloków i przeciągnij jakiś widget na nowe miejsce. Nazwa widgetcontaineru powinna być unikalna.
  11. Ja bym chętniej zapytał o radę kogoś z twojego (specjalnie z małej) forum, bo są tam takie tłumy, że na pewno ktoś zna rozwiązanie. Oj przepraszam zwracam honor, w tej chwili jest tam online aż 6 osób (w tym 2 gości). A odnośnie Ciebie, styl jest kradziony, radzę Ci go zmienić, bo prędzej czy później Twoją stroną zainteresują się odpowiednie osoby. PS. Możecie warnować.
  12. Witajcie, zaczynam swoją przygodę z pisaniem własnych aplikacji i chciałem zrobić prosty plugin, który zapisuje jakieś tam dane od użytkownika, żebym później mógł je gdzieś wykorzystać. Z tym drugim nie ma problemu, pojawia się on w przypadku pierwszego. Objaśnię to na screenach. Po kliknięciu w JHN Settings ma odpalić popupa z formularzem, jednakże formularz się nie ładuje: Po kliknięciu w JHN Settings jako adres podałem funkcję {$member->url()->setQueryString( 'do', 'jhnsettings' )} Stworzyłem hooka rozwijającego klasę \IPS\core\modules\front\member
  13. Witajcie, postanowiłem nauczyć się pisać własne widgety do IPS-a (używam wersji 4.4.4) na localhoście z trybem developera. Tworzę aplikację wyświetlającą cooke info (powiadomienie o używaniu plików cookies), w swoim widgetcie chciałbym wykorzystać obrazek, tylko pojawił się problem, jak go wczytać? Obrazek znajduje się w folderze cookiesinfo/dev/resources/cookies.png, plik css, w którym go wczytuję cookiesinfo/dev/css/cookieInfoCss.css, ta reguła nie działa {resource="cookies.png" app="core" location="global"} Bo odnosi się do folderu applications/core/dev/resources/global/cookies.png.
  14. Również pozdrawiam tę osobę, na pewno to czyta . Dziękuję za pomoc, usunąłem ten styl i że tak to ujmę zaćmienie umysłu zniknęło :p. Wystarczyło dopisać do .cke_toolgroup span.cke_button_icon[style*="icons.png"] .cke_toolgroup span.cke_button_icon[style*="icons.png"], .cke_toolgroup span.cke_button_icon[style*="icons_hidpi.png"] Ponieważ na wersji mobilnej ładowało z pliku editor.css ikony o nazwie icons_hidpi.png. Dziękuję za pomoc :P
  15. Podmienione, dziękuję jednakże na wersji mobilnej ikony są poprzestawiane. I nie, nie podmieniałem folderu. Z tego co widzę, to styl applications/core/interface/ckeditor/ckeditor/skins/ips/editor.css?t=J5CC nadpisuje mi powyższe zmiany. Edycja tego pliku nic nie daje, bo tak jakby IPS w ogóle nie czyta tego, że cokolwiek tam nadpiszę/edytuję. Dodane, dziękuję, jednakże nie do końca zadowala mnie to rozwiązanie i będę nad nim pracował, aby edytor działał poprawnie na wersji mobilnej.
×
×
  • Dodaj nową pozycję...