Skocz do zawartości
Pecetowicz Forum komputerowe

"Access level to Riode_Element_Section" | WooCommerce


Przejdź do rozwiązania Rozwiązane przez MFaldzinski,

Rekomendowane odpowiedzi

Hej, dziś napotkałem się z takim problemem w WordPress:

Fatal error: Access level to Riode_Element_Section::get_html_tag() must be protected (as in class Elementor\Element_Section) or weaker in /autoinstalator/wordpress/peps/peps/wp-content/plugins/riode-core/elementor/elements/riode-section.php on line 0

Jakieś propozycje jak to naprawić? Dodam, że wordpress, pluginy oraz motyw są zaktualizowane do najnowszej wersji.

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Administrator

@MFaldzinski Jeśli zakupiłeś motyw u jakiegoś dostawcy to zgłosiłbym mu błąd ewentualnie poprosił o rozwiązanie problemu o ile w cenę wliczona jest jakaś pomoc techniczna.

Jeśli nie to pozostaje wejść do pliku jak podaje błąd:

Cytat

/autoinstalator/wordpress/peps/peps/wp-content/plugins/riode-core/elementor/elements/riode-section.php

i znaleźć funkcję get_html_tag. Jeśli tam będzie taka funkcja podeślij kawałek kodu z nią związany (screen bądź tekstowo)

 

  • Lubię to! 1
  • Super 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert

A jaka wersja PHP? Może sam motyw jej nie wspiera.

  • Lubię to! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
1 godzinę temu, Mativve napisał:

@MFaldzinski Jeśli zakupiłeś motyw u jakiegoś dostawcy to zgłosiłbym mu błąd ewentualnie poprosił o rozwiązanie problemu o ile w cenę wliczona jest jakaś pomoc techniczna.

Jeśli nie to pozostaje wejść do pliku jak podaje błąd:

i znaleźć funkcję get_html_tag. Jeśli tam będzie taka funkcja podeślij kawałek kodu z nią związany (screen bądź tekstowo)

 

wrzuciłem cały plik na wklejto : KLIK
 

Godzinę temu, -n3veR napisał:

A jaka wersja PHP? Może sam motyw jej nie wspiera.

2 tyg strona działała prawidłowo a dziś wystąpił błąd.

Edytowane przez Mativve
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert
10 minut temu, MFaldzinski napisał:

wrzuciłem cały plik na wklejto : KLIK

Link nie działa. Wrzuć go po prostu w tekst, nie używaj WYSIWYG.

13 minut temu, MFaldzinski napisał:

2 tyg strona działała prawidłowo a dziś wystąpił błąd.

No ale co robiłeś przez te 2 tygodnie? Co aktualizowałeś?

Odnośnik do odpowiedzi
Udostępnij na innych stronach
54 minuty temu, -n3veR napisał:

Link nie działa. Wrzuć go po prostu w tekst, nie używaj WYSIWYG.

No ale co robiłeś przez te 2 tygodnie? Co aktualizowałeś?

Aktualizowałem wtyczki: elementor, woocommerce, dziś po całym błędzie zrobiłem aktualizację szablonu.

KOD:
http://www.wklejto.pl/910762

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert
Napisano (edytowane)

Ostatnio naprawiałem WP babce. I też był problem z Woo po aktualizacji.
Coś popsuli po prostu... Może inaczej, nie popsuli, a motyw nie był kompatybilny z najnowszym Woo. I w Twoim przypadku jest identycznie.

Pokaż jeszcze kod tej klasy: `Element_Section`

Edytowane przez -n3veR
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wyłączyłem plugin Riode Core - błąd zniknął wraz z zawartością strony.

Wyłączyłem plugin Elementor - błąd zniknął wraz z szata graficzna.

Napisałem też do pomocy technicznej autora motywu może pomogą..

Nie wiem czy mam jeszcze jakieś możliwości aby to naprawić czy czekać za supportem.

  • Lubię to! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert
Napisano (edytowane)

W pliku, który podałeś, zmień `private` na `protected` lub `public` (lub, bo nie dałeś mi tego pliku o który prosiłem 😄). Linia 134.

Jednak tak jak pisałem - supp powinien się tym zająć i zaktualizować motyw.

Edytowane przez -n3veR
  • Lubię to! 2
  • Dzięki! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Rozwiązanie
12 godzin temu, -n3veR napisał:

W pliku, który podałeś, zmień `private` na `protected` lub `public` (lub, bo nie dałeś mi tego pliku o który prosiłem 😄). Linia 134.

Jednak tak jak pisałem - supp powinien się tym zająć i zaktualizować motyw.

Odpisał mi support. Wina leżała po stronie Elementora tzn, najnowsza wersja Elementora nie jest jeszcze kompatybilna z motywem. Mam narazie nie aktualizować wtyczki do czasu wydania nowej aktualizacji motywu.

  • Lubię to! 2
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...