Skocz do zawartości
Pecetowicz Forum komputerowe

Błąd "Unknown error 1054" przy kopiowaniu grupy w Invision Community


Rekomendowane odpowiedzi

Witam, Zauważyłem, że na forum IPS pojawia mi się pewien błąd, gdy chcę skopiować jakąś grupę przez ACP. Błąd, który mi wyskakuje to: IPS\Db\Exception: Unknown error 1054 (1054). Dodam że aktualizacja oprogramowania Invision Community błędu nie naprawiła.

Cała treść błędu:

INSERT INTO `core_groups` ( `g_id`, `g_view_board`, `g_mem_info`, `g_other_topics`, `g_use_search`, `g_edit_profile`, `g_post_new_topics`, `g_reply_own_topics`, `g_reply_other_topics`, `g_edit_posts`, `g_delete_own_posts`, `g_open_close_posts`, `g_delete_own_topics`, `g_post_polls`, `g_vote_polls`, `g_use_pm`, `g_append_edit`, `g_access_offline`, `g_avoid_q`, `g_avoid_flood`, `g_icon`, `g_attach_max`, `prefix`, `suffix`, `g_max_messages`, `g_max_mass_pm`, `g_search_flood`, `g_edit_cutoff`, `g_hide_from_list`, `g_post_closed`, `g_photo_max_vars`, `g_dohtml`, `g_edit_topic`, `g_bypass_badwords`, `g_can_msg_attach`, `g_attach_per_post`, `g_topic_rate_setting`, `g_dname_changes`, `g_dname_date`, `g_mod_preview`, `g_rep_max_positive`, `g_rep_max_negative`, `g_signature_limits`, `g_hide_online_list`, `g_bitoptions`, `g_pm_perday`, `g_mod_post_unit`, `g_ppd_limit`, `g_ppd_unit`, `g_displayname_unit`, `g_sig_unit`, `g_pm_flood_mins`, `g_max_bgimg_upload`, `g_staffbox_view`, `g_staffbox_use`, `g_staffbox_posts_req`, `g_staffbox_posts_req_display`, `g_staffbox_bypass_flood`, `g_staffbox_edit`, `g_staffbox_delete_own`, `g_staffbox_view_archive`, `g_shoutbox_view`, `g_shoutbox_use`, `g_shoutbox_posts_req`, `g_shoutbox_posts_req_display`, `g_shoutbox_bypass_flood`, `g_shoutbox_edit`, `g_shoutbox_delete_own`, `g_shoutbox_view_archive`, `g_shoutbox_old_req`, `g_shoutbox_old_req_display`, `g_display`, `g_bitoptions2`, `g_upload_animated_photos`, `g_view_displaynamehistory`, `g_hide_own_posts`, `g_lock_unlock_own`, `g_can_report`, `g_create_clubs`, `g_club_allowed_nodes`, `g_close_polls`, `g_promote_exclude`, `note_add_perm`, `note_delete_perm`, `post_with_note_edit_perm`, `note_view_perm`, `g_club_limit`, `steam_pull`, `steam_index`, `group_id`, `g_dt_view`, `g_dt_donate`, `g_dt_view_goals`, `g_dt_view_donations`, `g_dt_send_donations`, `g_dt_moderate_donations`, `g_dt_view_topdonors` ) VALUES ( NULL, 1, 1, 1, 1, 1, 1, 1, 1, '1', '0', 0, 0, 1, 1, 1, 1, 0, 0, 0, NULL, 5000, '<span style="color: #d9d996;font-weight: bold;"><i aria-hidden="true" class="fab fa-steam-symbol"> </i> ', '<sup>JB</sup></span>', 100, -1, 0, 10000, 0, 0, '1000:300:300', 0, 1, 0, 1, 0, 2, 0, 1, 0, 10, 0, '0:1:600:150:2:10', 0, 1100742656, -1, 0, 0, 0, 0, 0, -1, -1, 1, 0, 0, 1, 0, 0, 0, 1, 1, 1, 0, 1, 0, 0, 0, 1, 0, 1, NULL, 0, 1, 0, '0', '0', '1', 'public,open,closed,private', '*', 1, 0, 0, 0, 1, 1, NULL, 1, 1, 32, 1, 1, 1, 1, 1, 0, 1 )
IPS\Db\Exception: Unknown error 1054 (1054)
#0 cs-creativ.pl/public_html/system/Db/Db.php(936): IPS\_Db->preparedQuery('/*m1213_m2HFdSN...', Array)
#1 cs-creativ.pl/public_html/system/Patterns/ActiveRecord.php(487): IPS\_Db->insert('core_groups', Array)
#2 cs-creativ.pl/public_html/system/Patterns/ActiveRecord.php(438): IPS\Patterns\_ActiveRecord->save()
#3 cs-creativ.pl/public_html/system/Member/Group.php(200): IPS\Patterns\_ActiveRecord->__clone()
#4 cs-creativ.pl/public_html/applications/core/modules/admin/members/groups.php(399): IPS\Member\_Group->__clone()
#5 cs-creativ.pl/public_html/system/Dispatcher/Controller.php(90): IPS\core\modules\admin\members\_groups->copy()
#6 cs-creativ.pl/public_html/applications/core/modules/admin/members/groups.php(39): IPS\Dispatcher\_Controller->execute()
#7 cs-creativ.pl/public_html/system/Dispatcher/Dispatcher.php(153): IPS\core\modules\admin\members\_groups->execute()

#9 {main}
Odnośnik do odpowiedzi
Udostępnij na innych stronach
5 minut temu, -n3veR napisał:

To jest defaultowa funkcjonalność w IPS? Bo Z tego co czytam, to jest kilka powodów dlaczego widzisz ten błąd: https://bobcares.com/blog/mysql-error-code-1054/

Forum odkupiliśmy niecały miesiąc temu, od tamtej pory błąd wyskakuję, dlatego nie jestem w stanie Ci powiedzieć czy ktoś coś ruszał przy bazie danych. 

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Założyciel

Zapytanie wygląda dobrze, choć może być tak że tabela 'core_groups' w bazie danych nie posiada jakiejś kolumny która jest w zapytaniu.

Błąd pojawia się tylko przy kopiowaniu czy również przy tworzeniu nowej grupy? Daj znać czy już się uporałeś z błędem. 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...