Skocz do zawartości
Pecetowicz Forum komputerowe

Cannot use "parent". Enhanced User Info Panel. Invision Community


Rekomendowane odpowiedzi

Cześć, jak niedawno się okazało wtyczka Enhanced User Info Panel od Adriano Faria nie wspiera wersji PHP 8 i wyrzuca błąd:

Cannot use "parent" when current class scope has no parent in /home/xxxxxxxxx/public_html/system/Theme/Theme.php(2612) : eval()'d code on line 53

Wiec pytanie, czy jest coś czym mógłbym to zastąpić lub ktoś by z chęcią napisał albo uaktualnił tą wtyczkę?

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Założyciel

Cześć. Jeżeli wtyczka byłaby od innego autora to mógłbym ją poprawić. Adriano ma tyle swoich wtyczek że zaktualizowanie wszystkich do IPS 4.6 wymaga pewnie czasu. Wtyczka zostanie pewnie zaktualizowana za czas jakiś. W między czasie możesz wystawić opinię dla nowych klientów że wtyczka nie działa na PHP 8.

Hi. If the plugin was from another author, I could fix it. Adriano has so many plugins that it takes some time to update all of them to IPS 4.6. The plugin will probably be updated in some time. In the meantime, you can leave a review for new customers that the plugin does not work on PHP 8.

  • Lubię to! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nie byłem pewny bo myślałem ze to to wtyczka Jackal a wiem zeros tam się narobiło miedzy nimi w lutym...No nic, napisałem do Adriano i czekam.

13 minut temu, SeNioR napisał:

In the meantime, you can leave a review for new customers that the plugin does not work on PHP 8.

Just double checked and I can confirm that Enhanced User Info Panel 2.1.1 is not available on the Marketplace, or I'm missing something.lol

  • Lubię to! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Założyciel

@edjazoli25 You are actually right. The plugin has been withdrawn from the Marketplace and Adriano wrote back to me that it will not be updated.

I do not have this plugin purchased, but you can send it to me on PM, then I will see what I can do.

  • Super 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Założyciel

Referring to the topic Theme Hook weirdness in 4.6,  its not 4.6 that is at fault per se, IPS is at some fault here due to the way they engineered how the theme hooks work, but it's the latest php 7.4 and 8.0 that is the issue.

I will send you a patched plugin on the PM which should work on PHP 8. 👍

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...