Skocz do zawartości

Conflicting declarations: 'CHARACTER SET utf8' and itf8mb4 MyBB


Pikaaczu.
 Udostępnij

Rekomendowane odpowiedzi

Witam podczas instalacji pluginu wyskakuje mi dany błąd:

Cytuj

SQL Error:

1302 - Conflicting declarations: 'CHARACTER SET utf8' and 'CHARACTER SET itf8mb4'


Query:
CREATE TABLE ”mybb_ann_slider” ( ”ann_id” INT NOT NULL AUTO_INCREMENT, ”title” TEXT NOT
NULL, ”description” TEXT NOT NULL, ” button_text” TEXT NOT NULL, ”button_Iink” TEXT NOT NULL,
date” TIMESTAMP DEFAULT CURRENT_TIMESTAMP, PRIMARY KEY (”ann_id” )) ENGINE = InnoDB
DEFAULT CHARSET=utf8 COLLATE=utf8_poIish_ci CHARACTER SET utf8mb4 COLLATE
utfemb4_general_ci

Screen:
 

Spoiler


Bardzo bym prosił o pomoc!

Odnośnik do komentarza
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
  • Podobna zawartość

    • Witam
      Posiadam zapytanie które tworzy tabele i kolumny, tylko do tych kolumn potrzebuje utf-8, ale nie wiem jak dodać, zapytanie wygląda tak:
      CREATE TABLE Test ( ID INT NOT NULL AUTO_INCREMENT PRIMARY KEY , Test_1 VARCHAR(200), Test_2 VARCHAR(200) );
    • Witam. Mam problem ze swoim forum. Gdy zainstalowałem forum, chciałem zrobić dział Regulamin, w jego opisie dałem polskie znaki. Jednak wchodząc na stronę główną to zamiast polskich znaków są pytajniki, myślałem że to wada stylu i zainstalowałem inny. Pomoże ktoś? A i jeszcze mam jeden problem, ponieważ gdy tworzę grupy to nie pokazują się one na stronie głównej, podobnie jest z innymi funkcjami PA. Zmieniłem rozmiary shoutboxa, dodałem że użytkownicy mogą usuwać swoje posty itp. i gdy wszystko zapisałem, to na stronie głównej nic się nie zmieniło. Nwm co się dzieje. Aha, silnik mojego forum to phpBB by Przemo 1.12.8. Z góry dzięki :).
    • Męcze się z tym formularzem i męcze.
      Ale nie mogę załapać polskich znaków....
      <?php // Tworzymy zmienną dla imienia i nazwiska $name = $_POST['name']; // Tworzymy zmienną dla adresu email $email = $_POST['email']; // Tworzymy zmienną dla wiadomości $message = $_POST['message']; // Podajesz adres email z którego ma być wysłana wiadomość $odkogo = "maro@maro.pe.hu"; // Podajesz adres email na który chcesz otrzymać wiadomość $dokogo = "maro@maro.pe.hu"; // Podajesz tytuł jaki ma mieć ta wiadomość email $tytul = "Wiadomość ze sklepu SHOPER[Formularz Kontaktowy]"; // Przygotowujesz treść wiadomości $wiadomosc = ""; $wiadomosc .= "Imie i nazwisko: " . $name . "\n"; $wiadomosc .= "Email: " . $email . "\n"; $wiadomosc .= "Wiadomość: " . $message . "\n"; // Wysyłamy wiadomość $sukces = mail($dokogo, $tytul, $wiadomosc, "Od: marus"); // Przekierowywujemy na potwierdzenie if ($sukces){ print "<meta http-equiv=\"refresh\" content=\"0;URL=potwierdzenie.php\">"; } else{ print "<meta http-equiv=\"refresh\" content=\"0;URL=error.html\">"; } ?> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> <link rel="stylesheet" type="text/css" href="ODNOSNIK DO CSS" /> </head> <body> <div id="formularz"> <form method="post" action="odnosnik do PHP"> <label>Imię i nazwisko</label> <input name="name" placeholder="Imię i Nazwisko" required> <label>Email</label> <input name="email" type="email" placeholder="Adres e-mail" required> <label>Wiadomość</label> <textarea name="message" placeholder="Napisz tu wiadomość" required></textarea> <input id="submit" name="submit" type="submit" value="Wyślij"> </form> </div>
  • Najnowsze tematy

  • Ostatnio rozwiązane

×