Skocz do zawartości
Pecetowicz Forum komputerowe

Domena nie reaguje na VirtualHost


Rekomendowane odpowiedzi

Hej, mam malutki problem.

Potrzebuję sobie przekierować subdomene na adres ip + port lecz po utworzeniu virtualhosta i po odpaleniu go ciągle domena wskazuje na adres ip serwera bez portu, przed odpaleniem vh wykonałem kroki aby odpalić moduły

  • a2enmod proxy
  • a2enmod proxy_http
  • a2enmod proxy_balancer
  • a2enmod lbmethod_byrequests
  • systemctl restart apache2
<IfModule mod_ssl.c>
    <VirtualHost *:443>

        ServerAdmin admin@xxx.pl
        ServerName panel.xxx.pl
        ServerAlias www.panel.xxx.pl

        ProxyPreserveHost On
        ProxyPass / http://127.0.0.1:8093/
        ProxyPassReverse / http://127.0.0.1:8093/

        ErrorLog ${APACHE_LOG_DIR}/error_lider.log
        CustomLog ${APACHE_LOG_DIR}/access_lider.log combined

        SSLEngine on
        SSLCertificateFile /etc/apache2/ssl/server.crt
        SSLCertificateKeyFile /etc/apache2/ssl/server.key

        <FilesMatch "\.(cgi|shtml|phtml|php)$">
            SSLOptions +StdEnvVars
        </FilesMatch>

        <Directory /usr/lib/cgi-bin>
            SSLOptions +StdEnvVars
        </Directory>
    </VirtualHost>
</IfModule>

 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...