Jump to content
Sign in to follow this  
SpeedRDM

Fuel PHP - Panel Gracza SA-MP. Wyskakuje błąd 404

Recommended Posts

Witam , mam problem z panelem opartym na fuelphp . Mianowicie działa tylko strona główna index.php gdy chce wejść w jakąś podstronę zwraca komunikat 404 ..

 

Jeżeli dodam /index.php/dalsza część to oczywiście działa. Wiem że problem może być w pliku .htaccess lecz niestety tam jest wszystko dobrze i nie mam pojęcia co może być nie tak. Strona umieszczona jest na serwerze vps.

 

Adres strony : petruck.pl

 

Dziękuje

Share this post


Link to post

Pokaż ten .htaccess

Share this post


Link to post

Proszę

Spoiler

# Multiple Environment config, set this to development, staging or production
# SetEnv FUEL_ENV production

<IfModule mod_rewrite.c>

  RewriteEngine on

  # NOTICE: If you get a 404 play with combinations of the following commented out lines
  #AllowOverride All
  #RewriteBase /wherever/fuel/is

  # Make sure directory listing is disabled
  Options +FollowSymLinks -Indexes

  # Restrict your site to only one domain
  # !important USE ONLY ONE OPTION

  # Option 1: To rewrite "www.domain.com -> domain.com" uncomment the following lines.
  #RewriteCond %{HTTPS} !=on
  #RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
  #RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

  # Option 2: To rewrite "domain.com -> www.domain.com" uncomment the following lines.
  #RewriteCond %{HTTPS} !=on
  #RewriteCond %{HTTP_HOST} !^www\..+$ [NC]
  #RewriteCond %{HTTP_HOST} (.+)$ [NC]
  #RewriteRule ^(.*)$ http://www.%1/$1 [R=301,L]

  # Remove index.php from URL
  #RewriteCond %{HTTP:X-Requested-With}	!^XMLHttpRequest$
  #RewriteCond %{THE_REQUEST}				^[^/]*/index\.php [NC]
  #RewriteRule ^index\.php(.*)$			$1 [R=301,NS,L]

  # make HTTP Basic Authentication work on php-fcgi installs
  <IfModule mod_fcgid.c>
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
  </IfModule>

  # Send request via index.php if not a real file or directory
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d

  # deal with php-fcgi first
  <IfModule mod_fcgid.c>
    RewriteRule ^(.*)$ index.php?/$1 [QSA,L]
  </IfModule>

  # no php-fcgi, check for sapi and fpm
  <IfModule !mod_fcgid.c>

    # for PHP5 sapi installations
    <IfModule mod_php5.c>
      RewriteRule ^(.*)$ index.php/$1 [L]
    </IfModule>

    <IfModule !mod_php5.c>

      # for PHP7 sapi installations
      <IfModule mod_php7.c>
        RewriteRule ^(.*)$ index.php/$1 [L]
      </IfModule>

      # for fpm installations
      <IfModule !mod_php7.c>
        RewriteRule ^(.*)$ index.php?/$1 [QSA,L]
      </IfModule>

    </IfModule>

  </IfModule>

</IfModule>

 

 

.htaccess

Share this post


Link to post

A na VPSie masz postawionego Apache'a czy Nginxa?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Create a New Account. It’s free and easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...