Skocz do zawartości

Jak dodać SSL i przekierowanie na HTTPS w MyBB


Krzysiek-
 Udostępnij

Przejdź do rozwiązania Rozwiązane przez SeNioR,

Rekomendowane odpowiedzi

Opublikowano
Opublikowano

Hey, co zrobić by po wpisaniu w przegladarke nazwa.pl odpalało strone z https a nie normalnie http? bo gdy wpisuje nazwa.pl to wywala obok strony "niezabezpieczona"

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano

A masz wgrany certyfikat na domenę?

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano

@KrzysiekHi Pomoc nazwa.pl: Certyfikat SSL

Jak wymusić szyfrowanie SSL?

Aby przed adresem Twojej strony internetowej widoczny był prefiks https oznaczający szyfrowanie danych, zainstaluj i włącz na serwerze certyfikat SSL, a w katalogu z plikami strony internetowej dodaj lub edytuj plik .htaccess, zawierający regułę przekierowania z http na https, np.

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Pomoc nazwa.pl: Jak wymusić szyfrowanie SSL dla strony internetowej na serwerze?

Odnośnik do komentarza
Udostępnij na innych stronach

  • Założyciel
  • Rozwiązanie
Opublikowano
Opublikowano

@KrzysiekHi Na początek musisz aktywować certyfikat SSL. Generujesz specjalny klucz. Certyfikat możesz zakupić lub wygenerować darmowy od Let's Encrypt.

Później zapewne trzeba pozmieniać w ustawieniach MyBB adres na ten z przedrostkiem HTTPS. A na koniec ustawić w htaccess przekierowanie z HTTP na HTTPS.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano

@SeNioR ja właśnie sobie wygenerowałem i mam przy włączaniu blokadę

Cytat

Certyfikat nie został włączony.

 

Koniecznie skontaktuj się z administratorem i opisz wykonywane czynności.

Lub przy wygenerowanym na nazwa.pl - 

Cytat

Przepraszamy, system jest chwilowo niedostępny, spróbuj za chwilę. Jeżeli sytuacja potrwa dłużej niż 15 minut skontaktuj się z Działem Obsługi Klienta.

Odnośnik do komentarza
Udostępnij na innych stronach

  • 1 rok później...
Opublikowano
Opublikowano

Dlaczego po dodaniu https przed nazwą domeny dzieje się coś takiego?
image.thumb.png.b26ab0ed2eeebb8acd9fc7e8ef31b47d.png

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano

Bo w CSS grafika ma odnośniki http, a nie https i temu tak się dzieje.

Jak przeczytasz dokumentację, to powinieneś dać sobie radę Setting up HTTPS - MyBB Documentation...

@Dawidofskyy Sprawdź też CTRL + F5.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
1 godzinę temu, Tomik napisał:

Bo w CSS grafika ma odnośniki http, a nie https i temu tak się dzieje.

Jak przeczytasz dokumentację, to powinieneś dać sobie radę Setting up HTTPS - MyBB Documentation...

 

@Dawidofskyy Sprawdź też CTRL + F5.

 

W headerinclude nie mialem nic do zmiany. CTRL + F5 nic nie dało.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
1 minutę temu, socjopata napisał:

@Dawidofskyy Masz włączony certyfikat SSL?

Jak to można sprawdzić?
Stronę mam na Server Project. Tam zleciłem podłączenie SSL.

Odnośnik do komentarza
Udostępnij na innych stronach

  • Premium
Opublikowano
Opublikowano

edytuj plik .htacces I dodaj:

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano
12 godzin temu, Dawidofskyy napisał:

W headerinclude nie mialem nic do zmiany. CTRL + F5 nic nie dało.

Nie pisałem nic o headerinclude. Proszę czytać ze zrozumieniem.

Tak czy siak odsyłam do dokumentacji, bo tam jest wszystko opisane.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
2 godziny temu, Tomik napisał:

 

Nie pisałem nic o headerinclude. Proszę czytać ze zrozumieniem.

 

Tak czy siak odsyłam do dokumentacji, bo tam jest wszystko opisane.

Zrobiłem wg. dokumentacji to również nie pomogło. A tam jest zawarte, że wszystkie http trzeba zamienić na https. Chyba, że coś źle zrozumiałem.

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano
2 godziny temu, Dawidofskyy napisał:

A tam jest zawarte, że wszystkie http trzeba zamienić na https. Chyba, że coś źle zrozumiałem.

Tak, dlatego po włączeniu konsoli ma ona mnóstwo błędów.

image.thumb.png.a09640839112e770a23816fa09d72908.png

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano

Teraz w ACP mam SSL, a na forum nie ;v

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano

No nadal nie zmieniłeś linków.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano (edytowane)
7 minut temu, aXenDev™ napisał:

No nadal nie zmieniłeś linków.

Gdzie mogę je znaleźć?
Szukam i nic ;v

Edytowane przez Dawidofskyy
Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
36 minut temu, Dawidofskyy napisał:

Gdzie mogę je znaleźć?
Szukam i nic ;v

W edycji stylu.

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano

@Dawidofskyy Pisałem Ci o tym na PW, a Ty nadal pytasz w kółko o to samo. Informatykiem jesteś bądź się uczysz, a nie potrafisz takich rzeczy?

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
14 minut temu, Tomik napisał:

@Dawidofskyy Pisałem Ci o tym na PW, a Ty nadal pytasz w kółko o to samo. Informatykiem jesteś bądź się uczysz, a nie potrafisz takich rzeczy?

Chłopie nie wiem gdzie mogę znaleźć to, tylko o to pytam...

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano
Przed chwilą, Dawidofskyy napisał:

Chłopie nie wiem gdzie mogę znaleźć to, tylko o to pytam...

No przecież style znajdują się w Style i szablony -> Style -> Twój styl, a szablony w Style i szablony -> Szablony -> Twój szablon.

W stylach edytujesz np. global.css, a w szablonach np. Nagłówek header. Musisz przejrzeć i zmienić linki.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
Przed chwilą, Tomik napisał:

 

No przecież style znajdują się w Style i szablony -> Style -> Twój styl, a szablony w Style i szablony -> Szablony -> Twój szablon.

W stylach edytujesz np. global.css, a w szablonach np. Nagłówek header. Musisz przejrzeć i zmienić linki.

Okej, robiłem tak. Używałem CTRL + F i wpisywałem http żeby wyszukało i nic.

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano
1 minutę temu, Dawidofskyy napisał:

Okej, robiłem tak. Używałem CTRL + F i wpisywałem http żeby wyszukało i nic.

Konsola mówi, że tego nie zrobiłeś.

Jako dowód mogę Ci podać kawałek kodu:

<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/global.css" />
<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/bxslider.css" />
<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/reyo.css" />

Tak naprawdę ten temat jest już wyczerpany.

Zamienisz linki to będzie Ci działać. My nic innego już nie wymyślimy.

Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano
1 minutę temu, Tomik napisał:

 

Konsola mówi, że tego nie zrobiłeś.

Jako dowód mogę Ci podać kawałek kodu:


<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/global.css" />
<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/bxslider.css" />
<link type="text/css" rel="stylesheet" href="http://demus.mtasa.eu/cache/themes/theme3/reyo.css" />

Tak naprawdę ten temat jest już wyczerpany.

Zamienisz linki to będzie Ci działać. My nic innego już nie wymyślimy.

Jak znajdę to, to zacznie działać. 
A jeszcze jedno, wiesz może dlaczego w ACP mam ssl, a na stronie już nie? Już pomijam fakt, że się nie ładuje styl.

Odnośnik do komentarza
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

×