Skocz do zawartości
Pecetowicz Forum komputerowe

Krzaki zamiast polskich liter w phpBB2 Przemo. Jak naprawić ?


Rekomendowane odpowiedzi

To akurat moja sprawa na czym siedzę, twój post nic nie wnosi do tego tematu, chciałbym uzyskać pomoc ,a  nie dostawać sugestie..

Aby emigrować do mybb też trzeba to umieć zrobić.

50 minut temu, Erasmux napisał:

Zmień kodowanie szablonu na UTF-8 bez BOOM.

Możesz mi to bardziej wyjaśnić? ☺️

Edytowane przez KiLLeReK
Odnośnik do odpowiedzi
Udostępnij na innych stronach

@KiLLeReK Należy przeczytać ten temat http://www.przemo.org/phpBB2/forum/viewtopic.php?t=17648

Wspomnę również, że jest problem ze stylem. Skrypt jest na 1.12.7, a styl jest niekompatybilny. (czyli np. skrypt na 1.12.7, a styl na 1.12.8)

Edytowane przez ShanonWEB
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert
Godzinę temu, SzewczeN napisał:

@KiLLeReK znajdz plik overall_header, przenieś go na pulpit, za pomocą programu notepad ++ edytuj plik.

W menu masz format --> koduj w UTF-8 (bez room) 

Zapisz plik i wrzuć ponownie na ftp.

Bez BOOM.

Odnośnik do odpowiedzi
Udostępnij na innych stronach
2 godziny temu, SzewczeN napisał:

@KiLLeReK znajdz plik overall_header, przenieś go na pulpit, za pomocą programu notepad ++ edytuj plik.

W menu masz format --> koduj w UTF-8 (bez room) 

Zapisz plik i wrzuć ponownie na ftp.

O ile to pomoże to styl jest pod 1.12.6, a pan ma 1.12.7, także to również należy zrobić, bo brak polskich znaków (krzaki) również objawia się gdy styl nie jest kompatybilny. (zresztą jest wiele innych oznak, że należy naprawić styl)

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert

Źle przeprowadzona migracja, bo po migracji nie powinno zmienić się kodowanie. Chyba, że bazę wgrałeś na inne kodowanie tabel - stąd ten problem.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Znaczy ogólnie tabele przemka były w bazie, przy instalacji forum nie mogłem użyć tych tabel co były więc po prostu podmieniłem w ftp plik config aby działały tabele przemka. ☺️ Mam nadzieję, że jakoś to ogarniasz co napisałem, bo trudno mi to opisać.

Edytowane przez KiLLeReK
Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert

Zawsze robi się kopię plików, właśnie na wypadek jakby coś poszło nie tak. Jeżeli masz jeszcze starą wersję bazy sprzed przejścia na archaicznego przemka, to przeprowadź migrację raz jeszcze.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ale ja nie przeprowadzałem migracji właśnie, po prostu mam bazę danych z przemkiem która już od dawna jest, więc zainstalowałem forum tylko, że nie chciało mi zainstalować z prefixem phpbb_ to podmieniłem config i wszystkie posty mam , które były kiedyś ale te krzaki jak nie można tego naprawić no to cóż poprawie najważniejsze tematy. ☺️

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Ekspert

Nie ma takiego kodowania (dla pliku, bo dla tabel w bazie tak). Jest samo utf8 albo utf8 (bez BOM) i to ostatnie jest zalecane dla naszych znaków diakrytycznych.

  • Lubię to! 1
Odnośnik do odpowiedzi
Udostępnij na innych stronach
Dnia 14.04.2017 o 19:53, KiLLeReK napisał:

Nie wiem jak to sprawdzić nadal, biorę te przeglądaj, a tu nic wyskakują same liczby.

 

Przejdź do phpmyadmin, a tam wybierz bazę. Następnie po prawej ujrzysz wszystkie tabele w bazie. Tam znajdziesz kodowanie. Zdjęcie poglądowe:

phpbb_baza1.thumb.jpg.998f7250d2d033c08573c58c3580e8c8.jpg

lub przejdź do tabeli, np. phpbb_post (klikając w nazwę), a następnie wybierz z górnego menu "Operacje" i ujrzysz kodowanie danej tabeli w tabelce. Zdjęcie poglądowe:

phpbb_baza2.thumb.jpg.1b9f06a6af539fa87e24b42eed60bbd5.jpg

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...