Skocz do zawartości

MyBB a PHP 8.1


Gość
 Udostępnij

Przejdź do rozwiązania Rozwiązane przez RiV,

Rekomendowane odpowiedzi

Gość
Opublikowano
Opublikowano

Siemka. Wie ktoś czy MyBB działa na PHP 8.1? 

Odnośnik do komentarza
Udostępnij na innych stronach

  • Premium
  • Rozwiązanie
Opublikowano
Opublikowano

Cześć. Wszystkie informacje znajdują się w dokumentacji. Maksymalna wersja wspierana przez MyBB to 7.4.

Wymagania MyBB

  • PHP ≥ 5.2, < 8.0
  • MySQL ≥ 5.0, PostgreSQL ≥ 8.1 or SQLite ≥ 3
  • Apache, nginx, lighttpd or IIS webserver

Poniższe rozszerzenia PHP są również wymagane:

  • SimpleXML
  • mbstring
  • gd
  • The respective vendor specific database PHP extension
Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano (edytowane)
14 minut temu, RiV napisał:

Maksymalna wersja wspierana przez MyBB to 8.0.

Nawet nie, bo jest znak mniejszości. Czyli jedynie 7.4 wchodzi w grę.

Chyba, że dokumentacja jest nieaktualna...

Edytowane przez -n3veR
Odnośnik do komentarza
Udostępnij na innych stronach

  • Premium
Opublikowano
Opublikowano (edytowane)
18 minut temu, -n3veR napisał:

Nawet nie, bo jest znak mniejszości. Czyli jedynie 7.4 wchodzi w grę.

Chyba, że dokumentacja jest nieaktualna...

Dzięki za uwagę, poprawiłem. Ale wydaje mi się że na PHP 8.0 też powinno hulać gdyż na githubie dodali jakieś hotfixy z tej wersji.
https://github.com/mybb/mybb/issues/4138

Edytowane przez RiV
Odnośnik do komentarza
Udostępnij na innych stronach

Opublikowano
Opublikowano

Próbowałem dziś przenieść na 8.0 niestety nie udało sie. Jedynie 7.4 

Odnośnik do komentarza
Udostępnij na innych stronach

  • Założyciel
Opublikowano
Opublikowano

PHP 8 nie jest wspierane, to znaczy na pewno 8.1.0, a z 8.0.0 są w różnych miejscach jeszcze problemy także zalecaną i najlepszą wersją obecnie będzie PHP 7.4.

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano (edytowane)

Swoją drogą, 7.4 za niedługo wypada z obiegu (koniec listopada), więc na 100% mają już przygotowany branch ze wsparciem pod 8.0, ale pewnie prace jeszcze trwają.

https://www.php.net/supported-versions.php

Edytowane przez -n3veR
Odnośnik do komentarza
Udostępnij na innych stronach

  • Założyciel
Opublikowano
Opublikowano
Godzinę temu, -n3veR napisał:

Swoją drogą, 7.4 za niedługo wypada z obiegu (koniec listopada)

Powiedz to osobą które wciąż używają phpBB2 i PHP 5.6, co jakiś czas natknę się na takie forum 😄 

Odnośnik do komentarza
Udostępnij na innych stronach

  • Ekspert
Opublikowano
Opublikowano
1 minutę temu, SeNioR napisał:

Powiedz to osobą które wciąż używają phpBB2 i PHP 5.6

Dług technologiczny jest z nami cały czas 😄 tylko nieliczni potrafią go spłacić xD 

To jak z kredytem w sumie 😄 

Odnośnik do komentarza
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
 Udostępnij

×