Jump to content
Sign in to follow this  
maniek19

Szablon Flatty - rozwalony widok ogłoszenia w dziale

Recommended Posts

Witam, wie ktoś może od czego taki problem?

59749a576b54c_Beztytuu.thumb.png.c15388a12a3eb7f20eb3a7ed01477a38.png

 

Zamiast normalnie wyświetlać to jak post, to jest jak jest... Z postbit_classic wszystko w porządku...

Share this post


Link to post

Nauczcie się do cholery dawać adres do strony i użytkownika testowego.

Zapytaj weź dżina, czy kogoś, a nie ☺️

  • Like 2

Share this post


Link to post

Twój problem na błędy postbit_classic. Daj wrzuć na kod tutaj. 

Share this post


Link to post
Guest chrumcio

@Mendelson. Niestety, niektórzy myślą że mamy kryształowe kule, a potem się dziwią że nikt nie odpisuje.

@maniek19

 

Share this post


Link to post

I z czym jest problem? Ja mam układ poziomo, poprawnie, nie pod avatarem jak pokazałeś na screenie

Share this post


Link to post

Możesz pokazać? Daj screena jak to wygląda. Tylko w takim wypadku dlaczego u mnie jest tak? Cache wyczyszczone...

Share this post


Link to post

No tak chłopaki, zgadza się  Posty jak najbardziej wyświetla poprawnie. Ale ja pisałem, że rozwalony widok OGŁOSZENIA

Link do ogłoszenia: Ogłoszenie: test

Share this post


Link to post
<div class="post_content">

Ten div jest za wcześnie wypisywany. Powinien być za <div class="post_author scaleimages"> a nie w nim.

Share this post


Link to post

@Szczwany Lis

post_content jest za post_author scaleimages

Moje postbit_classic:


{$ignore_bit}
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
<div class="post classic {$unapproved_shade}" style="{$post_visibility}" id="post_{$post['pid']}">
<div class="post_author scaleimages">
    <div class="author_information">
            <strong><span class="largetext">{$post['profilelink']}</span></strong><br />
            <span class="smalltext">
            <!--{$post['usertitle']}-->
            </span>
    </div>
    {$post['useravatar']}
    <center>
    {$post['groupimage']}
    </center>
    <div class="author_statistics">
    {$post['newpoints_postbit']}
    {$post['user_details']}
    
    </div>

<div class="post_content">
        <div class="post_head">
        {$post['posturl']}
        {$post['icon']}
        <span class="post_date"><i class="fa fa-clock-o fa_xtra pd"></i>{$post['postdate']} <span class="post_edit" id="edited_by_{$post['pid']}">            {$post['editedmsg']}</span></span>
    {$post['subject_extra']}
    </div>
    <div class="post_body scaleimages" id="pid_{$post['pid']}">
        {$post['message']}
    </div>
    {$post['xem_fast_rep']}
    {$post['attachments']}
    {$post['signature']}
    <div class="post_meta" id="post_meta_{$post['pid']}">
        {$post['iplogged']}
    </div>
</div>
<div class="post_controls">
    <span class="float_left" style="padding-left: 3px; padding-top: 7px; display: inline-block;">{$post['onlinestatus']}</span>
    <div class="postbit_buttons author_buttons float_left">
        {$post['button_pm']}{$post['button_www']}{$post['button_find']}{$post['button_rep']}
    </div>
    <div class="postbit_buttons post_management_buttons float_right">
        {$post['button_edit']}{$post['button_quickdelete']}{$post['button_quickrestore']}{$post['button_quote']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_purgespammer']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}
    </div>
</div>
</div>
</div>

Share this post


Link to post

@maniek19  Zobacz to, o jeden div jest błąd.

 

{$ignore_bit}
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
<div class="post classic {$unapproved_shade}" style="{$post_visibility}" id="post_{$post['pid']}">
<div class="post_author scaleimages">
    <div class="author_information">
            <strong><span class="largetext">{$post['profilelink']}</span></strong><br />
            <span class="smalltext">
            <!--{$post['usertitle']}-->
            </span>
    </div>
    {$post['useravatar']}
    <center>
    {$post['groupimage']}
    </center>
    <div class="author_statistics">
    {$post['newpoints_postbit']}
    {$post['user_details']}
    
    </div>
</div>
<div class="post_content">
        <div class="post_head">
        {$post['posturl']}
        {$post['icon']}
        <span class="post_date"><i class="fa fa-clock-o fa_xtra pd"></i>{$post['postdate']} <span class="post_edit" id="edited_by_{$post['pid']}">            {$post['editedmsg']}</span></span>
    {$post['subject_extra']}
    </div>
    <div class="post_body scaleimages" id="pid_{$post['pid']}">
        {$post['message']}
    </div>
    {$post['xem_fast_rep']}
    {$post['attachments']}
    {$post['signature']}
    <div class="post_meta" id="post_meta_{$post['pid']}">
        {$post['iplogged']}
    </div>
</div>
<div class="post_controls">
    <span class="float_left" style="padding-left: 3px; padding-top: 7px; display: inline-block;">{$post['onlinestatus']}</span>
    <div class="postbit_buttons author_buttons float_left">
        {$post['button_pm']}{$post['button_www']}{$post['button_find']}{$post['button_rep']}
    </div>
    <div class="postbit_buttons post_management_buttons float_right">
        {$post['button_edit']}{$post['button_quickdelete']}{$post['button_quickrestore']}{$post['button_quote']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_purgespammer']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}
    </div>
</div>
</div>

 

  • Like 1

Share this post


Link to post

Hah, powiązanie jakieś mają ze sobą  Chwilę jeszcze popatrzę na kod i może coś wykombinuje

 

//Edit

Zauważyłem że ogłoszenia nawet nie dostają swojego id przy postach, także możliwe, że warunki nie są wtedy prawidłowo sprawdzane i kod się sypie.

Edited by Szczwany Lis
  • Like 1

Share this post


Link to post

Kiedyś właśnie już tak miałem, że ten widok posta się popierdzielił. Wtedy właśnie z post_content i post_controls coś przestawiałem, bo tak mi poradzili i pomogło. Ale widocznie tym sposobem popsuł się widok ogłoszenia. Tylko ciekawe dlaczego wtedy ni stąd ni zowąd popsuł się widok posta... Hmm :[

Share this post


Link to post

Swój szablon mają z tego samego pliku, więc są ze sobą połączone, ale nie przyjmują takich samych wartości, a podobne i może dlatego się to sypać, taka jest moja teoria. Nie korzystałem z MyBB to dokładnie Ci nie powiem.

Share this post


Link to post

A można to jakoś rozdzielić? Najlepiej to chyba byłoby dla ogłoszenia inny szablon i dla postu inny...

Share this post


Link to post

Jak Ci pomóc skoro jest taki komunikat?

 

Wybrane ogłoszenie jest nieprawidłowe.

 

 

Edited by Mendelson.

Share this post


Link to post

CSS do ogłoszenia umieść w oddzielnym szablonie i sprawdź czy w kodzie nie znajduje się zbędny <div class="#"> lub <div id="#">

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Create a New Account. It’s free and easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...