Skocz do zawartości
Forum komputerowe

Szablon MyBB od Cwaniak. Brak HTML w poście.


Rekomendowane odpowiedzi

Witam mam problem w MyBB z szablonem od Cwaniak. Gdy piszę nowy post i dodaję w edytorze kod HTML to kod nie jest formatowany tylko wyświetla się w formie RAW.

W szybkiej odpowiedzi jest dobrze.

Link do forum http:// globalplay.gameclan.pl 

Screenshot_1.png

Odnośnik do odpowiedzi
Udostępnij na innych stronach
  • Założyciel

Cześć Marek. Domyślny edytor w MyBB czyta tylko język formatowania BBCode. Kiedyś skrypty for nie miały odpowiednich zabezpieczeń i opcji które by to kontrolowały, Przy użyciu HTML można było zaimplementować złośliwy kod. Używanie HTML przez zwykłych użytkowników mających dostęp do źródła w dalszym ciągu jest niebezpieczne. Dlatego też powstał język BBCode. Język gwarantuje większe bezpieczeństwo i jest łatwiejszy w rozumieniu przez użytkownika.

Jeżeli chcesz aby edytor czytał HTML to skorzystaj z pluginu HTML in Posts lub wgraj plugin który podmienia domyślny edytor na bardziej zaawansowany. Proponowałbym CKEditor do MyBB który jest zresztą u nas na forum.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

 Niestety po zainstalowaniu CKEditor do mybb  znika pole szybkiej odpowiedzi . Mozliwe ze mozna to szybko naprawic. Instalacja Rin Editor pomogla  tu zas gdy pisze post i dam podglad wyskakuje ze nie musze wpisac tekst za to w szybkiej odpowiedzi dziala podglad poprawnie, Mysle ze dam rade juz to sam poprawic,

Dziekuje za pomoc mysle ze temat do zamkniecia. 

Edytowane przez Marek Hrubeniuk
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wciąż nierozwiązany? Dodaj swoją odpowiedź

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto. Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się
×
×
  • Dodaj nową pozycję...