Skocz do zawartości

Wyłączenie Strict Mode w MySQL 5 pod plugin Servers Board 3


kickac
 Udostępnij

Rekomendowane odpowiedzi

Witam, mam problem z instalacją servers board 3.2

A dokładniej chodzi o to:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1101 - BLOB, TEXT, GEOMETRY or JSON column 'buddylist' can't have a default value
Query:
CREATE TABLE mybb_serversboard ( `sid` int(10) unsigned NOT NULL AUTO_INCREMENT, `ip` varchar(35) NOT NULL DEFAULT '0', `arma2qport` varchar(30) NOT NULL DEFAULT '', `arma3qport` varchar(30) NOT NULL DEFAULT '', `bf3qport` varchar(30) NOT NULL DEFAULT '', `bf4qport` varchar(30) NOT NULL DEFAULT '', `dayzqport` varchar(30) NOT NULL DEFAULT '', `dayzmodqport` varchar(30) NOT NULL DEFAULT '', `minecraftqport` varchar(30) NOT NULL DEFAULT '', `mtaqport` varchar(30) NOT NULL DEFAULT '', `mumbleqport` varchar(30) NOT NULL DEFAULT '', `rustqport` varchar(30) NOT NULL DEFAULT '', `terrariaqport` varchar(30) NOT NULL DEFAULT '', `ts3qport` varchar(30) NOT NULL DEFAULT '10011', `type` varchar(20) NOT NULL DEFAULT '0', `offlinehostname` varchar(100) NOT NULL DEFAULT '', `cuthostname` varchar(3) NOT NULL DEFAULT '', `disporder` int(10) NOT NULL DEFAULT '0', `field` int(1) NOT NULL default '0', `field_link` varchar(100) NOT NULL DEFAULT '', `field_icon` varchar(100) NOT NULL DEFAULT '', `visible` int(1) NOT NULL default '1', `new` int(1) NOT NULL default '0', `new_color` varchar(20) NOT NULL DEFAULT '', `new_text` varchar(20) NOT NULL DEFAULT '', `forumid` varchar(20) NOT NULL DEFAULT '', `buddylist` TEXT NOT NULL DEFAULT '', `cache` LONGTEXT NOT NULL DEFAULT '', `lastupdate` bigint(30) NOT NULL DEFAULT '0', `recordplayers` int(10) NOT NULL DEFAULT '0', `owner` varchar(100) NOT NULL DEFAULT '', `administrators` varchar(100) NOT NULL DEFAULT '', PRIMARY KEY (`sid`) ) ENGINE = MYISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;
Please contact the MyBB Group for technical support.
Odnośnik do komentarza
Udostępnij na innych stronach

Problem rozwiązany: Dzięki za pomoc ☺️

Disable MySQL 5 "Strict Mode" on an Ubuntu

1. We first need to establish if strict mode is enabled on the MySQL server. To check this, type the command below on a terminal server:

$ sudo mysql -u root -p

Enter your MySQL database root password and press Enter.

Then, you will need to run the query below on the MySQl command prompt:

$ SHOW VARIABLES LIKE 'sql_mode';

A table is displayed on the screen with some sql_mode values separated with commas as shown below. If you find a value like “STRICT_TRANS_TABLES”, then, MySQL strict mode is enabled.

Step 2: Create a new configuration file using a nano editor

Using a nano editor, create a new configuration file under the /etc/mysql/conf.d/ directory. The new configuration file will override the default MySQL configuration file.

Use the command below:

$ sudo nano /etc/mysql/conf.d/disable_strict_mode.cnf

Then, enter the text below on the text editor:

[mysqld]
sql_mode=IGNORE_SPACE,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

Press CTRL +X and Y to save the changes.

Step 3: Restart MySQL

When you make any change to any MySQL configuration directory, you should restart MySQL service for the changes to take effect using the command below:

$ sudo service mysql restart
Odnośnik do komentarza
Udostępnij na innych stronach

Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

×