Skocz do zawartości
W Naszym sklepie znajdziesz wiele skinów do cs go, konkurencyjne ceny i natychmiastowa wysyłka to Nasza dywiza!
  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

MateoFF

Wymuszenie innej wersji PHP w wybranym, jednym katalogu

Promowane odpowiedzi

Cześć, cała strona stoi na php 7.0 jednak potrzebuję żeby tylko jeden katalog używał php 5.4 

Ktoś mi poradzi jak to zrobić? 
Hosting nazwa.pl

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Możesz wrzucić do tego katalogu .htaccess - o ile masz Apache - z taką zawartością:

<Files *.php>
	ForceType application/x-httpd-php56
</Files>

Chociaż nie wiem czy to zadziała.

  • Lubię to! 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

to stwórz nowy  .htaccess w tym katalogu i dodaj 

AddHandler application/x-httpd-php54 .php # php5.4

 

lub dodaj to do aktulanego .htaccess

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nadal mi to nie pomaga, może bardziej przybliżę mój problem. 
Otóż nie mogę wgrać amxbans, na jednym z forum powiedziano mi, że to problem z php, mam 7.0, a potrzeba 5.4. 

Błąd podczas próby instalacji:


Warning: Creating default object from empty value in /home/fastfrag/ftp/bany/setup.php on line 12
Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /home/fastfrag/ftp/bany/include/smarty/Smarty_Compiler.class.php on line 270

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W tym katalogu nie ma tego pliku, ja go tworzę z zawartością 

 

<Files *.php>
  AddHandler fcgi/php-5.4 .php54
</Files>

Natomiast jeśli utworzę z taką zawartością jak Ty mi podałeś to pobiera mi tak plik. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony.


×