Skocz do zawartości
vaandee

zapytanie do sql dla SF cba.pl

Promowane odpowiedzi

krótko, nie wiem jak wykonac poprawnie zapytaie do sql dla spider friendly;;

tu daje zapytanie;

INSERT INTO phpbb_config (config_name, config_value)

VALUES('sf_mod_rewrite_enabled', 1),

	('sf_rewrite_all_htm', 1),

	('sf_rewrite_index', 0),

	('sf_rewrite_mode', 1),

	('sf_simplify_pages', 1),

	('sf_charset_mapping', 'auto'),

	('sf_fake_dirs', 1),

	('sf_postlink_rewrite', 0),

	('sf_max_keywords_length', 768),

	('sf_sitemap_enabled', 1),

	('sf_show_lastpost_link', 0),

	('sf_map_index_only', 1),

	('sf_map_mode_listonly', 1),

	('sf_topics_per_page', 30),

	('sf_log_spiders', 1),

	('sf_spider_session_length', 3600),

	('sf_cache_refresh_mode', 'post'),

	('sf_cache_read_mode', 'file-direct'),

	('sf_show_bots_on_index', 1),

	('sf_shmop_lasttoken', -1);

CREATE TABLE phpbb_spider_log (

  log_id mediumint(8) NOT NULL auto_increment,

  spider_name varchar(255) NOT NULL default '',

  spider_firstvisit int(11) NOT NULL default '0',

  spider_lastvisit int(11) NOT NULL default '0',

  spider_hits mediumint(8) NOT NULL default '0',

  PRIMARY KEY (log_id),

  KEY spider_lastvisit (spider_lastvisit)

);

ALTER TABLE phpbb_sessions ADD session_bot VARCHAR(255) NOT NULL default '';

ALTER TABLE phpbb_sessions ADD INDEX (session_bot(2));

moje nazwy tabeli phpbb_4...

jak to podmienic i gdzie jak ktos mi to podmieni stawiam piwko

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sprawdź:

INSERT INTO phpbb_config (config_name, config_value)
VALUES('sf_mod_rewrite_enabled', 1),
('sf_rewrite_all_htm', 1),
('sf_rewrite_index', 0),
('sf_rewrite_mode', 1),
('sf_simplify_pages', 1),
('sf_charset_mapping', 'auto'),
('sf_fake_dirs', 1),
('sf_postlink_rewrite', 0),
('sf_max_keywords_length', 768),
('sf_sitemap_enabled', 1),
('sf_show_lastpost_link', 0),
('sf_map_index_only', 1),
('sf_map_mode_listonly', 1),
('sf_topics_per_page', 30),
('sf_log_spiders', 1),
('sf_spider_session_length', 3600),
('sf_cache_refresh_mode', 'post'),
('sf_cache_read_mode', 'file-direct'),
('sf_show_bots_on_index', 1),
('sf_shmop_lasttoken', -1);
CREATE TABLE phpbb_4_spider_log (
log_id mediumint(8) NOT NULL auto_increment,
spider_name varchar(255) NOT NULL default '',
spider_firstvisit int(11) NOT NULL default '0',
spider_lastvisit int(11) NOT NULL default '0',
spider_hits mediumint(8) NOT NULL default '0',
PRIMARY KEY (log_id),
KEY spider_lastvisit (spider_lastvisit)
);
ALTER TABLE phpbb_sessions ADD session_bot VARCHAR(255) NOT NULL default '';
ALTER TABLE phpbb_sessions ADD INDEX (session_bot(2)); [/code]

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
2013-02-26, 21:12"]Sprawdź:

wraz to samo :(

dorzucam screena moze cos wam podpiwe bo ja sam nie dojde;

3978a5c5605b1.png.html

http://zapodaj.net/3978a5c5605b1.png.html

btw. najpierw skopiowalem all pliki + pliki ktore ja edytoalem a teraz mecze sie nad zapytaniem, moze trzeba bylo inaczej to zrobic tzn odrotnie xd

adres forum; www.forumspartacus.cba.pl

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

vaandee, jak ma nie być to samo, skoro podał ci podmianę do jednego zapytania. Wykonaj to co ja ci napisałem.

"Zmień prefix z phpbb_ na: phpbb_4 jeżeli taki masz."

[ Dodano: 2013-02-26, 21:40 ]

Do tego edytuj plik config.php i wprowadź poprawne dane do bazy.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
2013-02-26, 21:40"]vaandee, jak ma nie być to samo, skoro podał ci podmianę do jednego zapytania. Wykonaj to co ja ci napisałem.

"Zmień prefix z phpbb_ na: phpbb_4 jeżeli taki masz."

[ Dodano: 2013-02-26, 21:40 ]

Do tego edytuj plik config.php i wprowadź poprawne dane do bazy.

forum juz sie pojawilo, niestety tylko strona glowna po probie zalogowania albo odpalenia jakiegos tematu wyskakuje ze podana stroan nie istnieje :/ o co moze chodzić?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W tabeli phpbb2_4config poszukaj adresu forum, i zmień na swój.

[ Dodano: 2013-02-27, 15:03 ]

Do tego w plikach overall_header sprawdź czy są dobre dane do strony z logowaniem, np "login.php"

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

jak nazwy tabel mam phpbb_4... to gdzie musze wpisac tą czworkew ktore miejsca? ; /

CREATE TABLE `phpbb_seotags` (`threadid` int(10) unsigned NOT NULL, `tag` varchar(100) NOT NULL, KEY `threadid` (`threadid`), FULLTEXT KEY `tag` (`tag`));


INSERT INTO phpbb_config VALUES ('seotags_indexcloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_indexcloud_num', '50');

INSERT INTO phpbb_config VALUES ('seotags_indexcloud_method', 'p');


INSERT INTO phpbb_config VALUES ('seotags_tagscloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_tagscloud_num', '200');

INSERT INTO phpbb_config VALUES ('seotags_tagscloud_method', 'r');


INSERT INTO phpbb_config VALUES ('seotags_forumcloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_forumcloud_num', '100');


INSERT INTO phpbb_config VALUES ('seotags_similar', '1');

INSERT INTO phpbb_config VALUES ('seotags_similar_num', '30');


INSERT INTO phpbb_config VALUES ('seotags_tags_separator', ', ');

INSERT INTO phpbb_config VALUES ('seotags_topics_per_page', '25');

INSERT INTO phpbb_config VALUES ('seotags_posts_words', '150');


ALTER TABLE `phpbb_topics` ADD `topic_autotagged` TINYINT NOT NULL DEFAULT '0';
ja uzupelnilem tak;
CREATE TABLE `phpbb_4seotags` (`threadid` int(10) unsigned NOT NULL, `tag` varchar(100) NOT NULL, KEY `threadid` (`threadid`), FULLTEXT KEY `tag` (`tag`));


INSERT INTO phpbb_config VALUES ('seotags_indexcloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_indexcloud_num', '50');

INSERT INTO phpbb_config VALUES ('seotags_indexcloud_method', 'p');


INSERT INTO phpbb_config VALUES ('seotags_tagscloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_tagscloud_num', '200');

INSERT INTO phpbb_config VALUES ('seotags_tagscloud_method', 'r');


INSERT INTO phpbb_config VALUES ('seotags_forumcloud', '1');

INSERT INTO phpbb_config VALUES ('seotags_forumcloud_num', '100');


INSERT INTO phpbb_config VALUES ('seotags_similar', '1');

INSERT INTO phpbb_config VALUES ('seotags_similar_num', '30');


INSERT INTO phpbb_config VALUES ('seotags_tags_separator', ', ');

INSERT INTO phpbb_config VALUES ('seotags_topics_per_page', '25');

INSERT INTO phpbb_config VALUES ('seotags_posts_words', '150');


ALTER TABLE `phpbb_4topics` ADD `topic_4autotagged` TINYINT NOT NULL DEFAULT '0';
i wyskoczyl taki blad;
Błąd


Zapytanie SQL:


CREATE TABLE `phpbb_4seotags` (

`threadid` int( 10 ) unsigned NOT NULL ,

`tag` varchar( 100 ) NOT NULL ,

KEY `threadid` ( `threadid` ) ,

FULLTEXT KEY `tag` ( `tag` )

);


MySQL zwrócił komunikat: Dokumentacja

#1050 - Table 'phpbb_4seotags' already exists 

Jak juz raz wykonam zle zapytanie to stworzy sie bledna tabela ? powinenem ja usunac? nie ogarniam ;__; bo nawet jak szukalem to nie moglem znalexc tabeli

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

×